Audiophile's Blog
Логин:Пароль:


Забыл пароль | Регистрация (убрать всю рекламу)
На сайт | Новые сообщения | Участники | Правила форума | Поиск | RSS
» » » »
Страница 1 из 11
Модератор форума: mrmerak, krivenchenko 
Форум » Воспроизведение аудио » Настройка Windows, драйверов » Настройка Creative Sound Blaster 5.1 pro и foobar2000 (проблема с ASIO)
Настройка Creative Sound Blaster 5.1 pro и foobar2000
EvisДата: Среда, 23 Сентября 2015, 19:18 | Сообщение # 1
Группа: Проверенные
Сообщений: 4
Статус: Offline
Доброго всем времени суток!
Что мы имеем:
- CarPC
- Creative Sound Blaster 5.1 pro
- Kicx KAP 5.1

Слушал себе музыку через AIMP, радовался 10-и канальному эквалайзеру и прочим фичам от креатива, но тут случайно нарвался на статью и понеслось. Скачал foobar2000, поставил все плагины, которые описаны в выше упомянутой статье, настроил более менее звук, приятный уху и...

...и принялся настраивать ASIO. Но все не тут то было.
Для начала давайте покажу пару скринов того, что у меня есть.












Как видно из скринов, стоят последние драйвера и последнее ПО с оф.сайта. НО!!! Кликая на трей, нет выбора режимов карты. Audio Creation Mode соответственно я тоже нигде не нашел, для того чтобы поменять герцовку и радоваться жизни.
Ладно с модом, но ведь и более широких настроек нигде нет.
Пробовал ставить Creative Console Launcher отдельно, не помогло. Изменилось количество кнопок в Entertainment Console. А полноценной оболочки так и не появилось. Пробовал удалять все под корень, ставить только Console Launcher, на что получал ответ - нет поддерживаемого устройства. Удалял и заново ставил драйвера с офф.сайта.

Подскажите, люди добрые, куда копать?
Ведь поддержка ASIO уже встроена в USB драва, и должна работать на ура!

Ах да, еще момент. Через foodbar работают только фронтальные динамики и НЧ (сабвуфер). Через AIMP все норма. Но это я думаю второстепенная проблема, ведь если зарабоает ASIO, то там все и настрою поканально.

P.S прошу прощения за качество скринов... Темно...

Добавлено (23 Сентября 2015, 19:18)
---------------------------------------------
Смотря вот на эту статью, становиться не понятно, почему у меня EnterTainment Mode выглядит не так.
А еще смущает фраза 
Цитата
Однако драйвера обеих карт для Windows 7/8 не поддерживают работу в режиме 44 кГц: в настройках устройства можно выставить только 48 кГц либо 96 кГц. Явная недоработка, о которой мы уведомили производителя. ASIO-драйверов пока что нет, но будем надеяться на лучшее.
из данной статьи.
И прочитав ее до конца, я в принципе нашел ответ на свой вопрос... Походу не судьба мне настроить foobar через ASIO.

И если посмотреть внизу на вопрос-ответ, то
Цитата
1. Появилась ли поддержка 44100Гц?
2. Появилась ли поддержка ASIO?
3. Есть ли поддержка EAX в играх и если нет, чем это грозит?
Спасибо!

1. нет, и не будет у этих устройств никогда. производители решили, что на устранении этих недочетов имеют право хорошо заработать.
2. аналогично

Но не понятно осталось одно! Почему тогда на офф.сайте написано


Цитата
Please be informed that ASIO is supported by the following Sound Blaster sound cards:
Sound Blaster X7Sound Blaster E5Sound Blaster E3 (ASIO playback only)Sound Blaster E1 (ASIO playback only)Sound Blaster R3/A6USound Blaster ZxR, Sound Blaster Zx, Sound Blaster ZSound Blaster Omni Surround 5.1 (ASIO playback only)Sound Blaster Digital Music Premium HD/X-Fi HD (ASIO playback only)Sound Blaster X-Fi Surround 5.1 Pro (ASIO playback only)Sound Blaster X-Fi series namely: X-Fi Titanium HD, X-Fi Titanium Professional Audio, PCI Express X-Fi Titanium, X-Fi Titanium Fatal1ty Pro, X-Fi Titanium Fatal1ty Champion, X-Fi Titanium, X-Fi Fatal1ty FPS, X-Fi Elite Pro, X-Fi Platinum, X-Fi XtremeMusic, X-Fi XtremeGamer, X-Fi XtremeGamer Fatal1ty Pro, X-Fi Platinum Fatal1ty Champion, X-Fi Fatal1ty Platinum, X-Fi Fatal1ty excluding Sound Blaster X-Fi Xtreme Audio and PCI-Express X-Fi Extreme Audio
Sound Blaster Audigy 5/RxSound Blaster Audigy 4 ProSound Blaster Audigy 2 ZS SeriesSound Blaster Audigy 2 Series (excluding Sound Blaster Audigy 2 LS)Sound Blaster Audigy SeriesEMU sound cards - The EMU line is designed specifically to take advantage of ASIO for multichannel, high quality, and low-latency audio recording and production.

Last updated: May 25, 2015


И еще один момент. Если все же не получится настроить через ASIO, то как сделать, чтобы работали все колонки?


Сообщение отредактировал Evis - Среда, 23 Сентября 2015, 19:21
 
AudiophileДата: Среда, 23 Сентября 2015, 22:19 | Сообщение # 2


Группа: Администраторы
Сообщений: 1052
Статус: Offline
Evis, эта карта - не полноценный X-Fi.

Если показывает "ASIO: Creative Sound Blaster ASIO" - значит драйвера есть. Что 44100 они не держат - уже другая проблема, тут может дело в самом чипе DSP. Ну да ерунда. Ставьте в DSP foobar2000 ресемплер до 96000, в настройках драйверов тоже конечно опорную 96 кГц, и слушайте.

А для разведения на более чем 2 канала юзайте DSP Channel Mixer для плеера (при WASAPI и ASIO обработчик встроенный в драйвер, который разводил каналы, отключается - потому и идёт стерео только).
 
EvisДата: Пятница, 25 Сентября 2015, 08:01 | Сообщение # 3
Группа: Проверенные
Сообщений: 4
Статус: Offline
Выставил настройки как Вы описали, ошибка не уходит и звука соответственно тоже нема. DSP Channel Mixer поставил, все замечательно, работают все каналы. Но хочется все же ASIO...
 
RollinnnДата: Пятница, 25 Сентября 2015, 09:13 | Сообщение # 4


Группа: Эксперты
Сообщений: 769
Статус: Offline
Нормально работающие ASIO драйвера - большая редкость. Овчинка выделки не стоит. Чем wasapi не устраивает?

Абсурдистан А ты тоже где-то читал, что фубар задирает высокие?
FLAC1.3.1noSSE2 LAME3.99.5ICL12.1 Monkey'sAudio4.10
 
EvisДата: Пятница, 25 Сентября 2015, 16:11 | Сообщение # 5
Группа: Проверенные
Сообщений: 4
Статус: Offline
Через WASAPI тоже почему то не хочет играть. Хотя плагин стоит, все норм... Может есть какая то особенность?
 
RollinnnДата: Пятница, 25 Сентября 2015, 16:43 | Сообщение # 6


Группа: Эксперты
Сообщений: 769
Статус: Offline
Цитата Evis ()
Через WASAPI тоже почему то не хочет играть
Т.е. совсем никак? Или без ресемплера в плеере? И event и push не работают?

Цитата Evis ()
ошибка не уходит

Ну если Вы правильно настроили ресемлер в фубаре на 96000, то фубар уже никак не может выдавать ошибку про "441000 Hz is not supported".
Покажите, что у Вас вообще в DSP в фубаре и конкретно настройки ресемплера.


Абсурдистан А ты тоже где-то читал, что фубар задирает высокие?
FLAC1.3.1noSSE2 LAME3.99.5ICL12.1 Monkey'sAudio4.10
 
EvisДата: Понедельник, 28 Сентября 2015, 08:33 | Сообщение # 7
Группа: Проверенные
Сообщений: 4
Статус: Offline
Скачал foobar2000 by Audiophile, перенастроил ресемплер и все заработало. От звука просто офигел! Разница неимоверная! Осталась одна проблема - при включении ПК, звуковая карта начинает издавать звуки, бум-бум-бум и при этом лампочка питания то загорится, то потухнет. Не может запуститься в общем. Помогает следующее. Вытаскиваю кабель питания и втыкаю заново. Бывает не с первого раза помогает, а несколько раз надо делать. Спрашивал у человека, который юзал такую же звуковушку, сказал что была такая беда. Потом он переустановил ОС и драйвера и стало нормально. Я послушав его, вчера перешел на Windows 10, поставил весь софт и драйвера, а толку нема. Попробовать семерку поставить... В панеле управления, звуки, все устройства кроме креатива удалил...

Добавлено (28 Сентября 2015, 08:33)
---------------------------------------------
Проблему вроде как решил. Поставил Windows 7 и драйвера предпоследние. Пока что все работает изумительно! Спасибо за помощь!

 
Форум » Воспроизведение аудио » Настройка Windows, драйверов » Настройка Creative Sound Blaster 5.1 pro и foobar2000 (проблема с ASIO)
Страница 1 из 11
Поиск:

Copyright Taras Kovrijenko © 2009–2016